aboutsummaryrefslogtreecommitdiff
path: root/flake.nix
diff options
context:
space:
mode:
authorMiguel Ángel Moreno <mail@migalmoreno.com>2024-11-05 00:03:33 +0100
committerMiguel Ángel Moreno <mail@migalmoreno.com>2024-11-05 01:18:10 +0100
commit50ca1ec0cff2ab978945d660c7e1ad4da59a431e (patch)
treefe61adfa41ae05615fdcf4027d93d1ec7ec1039a /flake.nix
parent6b9bede275430bc13059e1c5079a1460b033e75d (diff)
chore: add Nix flake and clean up ignore files
Diffstat (limited to 'flake.nix')
-rw-r--r--flake.nix22
1 files changed, 22 insertions, 0 deletions
diff --git a/flake.nix b/flake.nix
new file mode 100644
index 0000000..d251687
--- /dev/null
+++ b/flake.nix
@@ -0,0 +1,22 @@
+{
+ inputs = {
+ nixpkgs.url = "github:nixos/nixpkgs/nixos-unstable";
+ systems.url = "github:nix-systems/default";
+ };
+ outputs =
+ { nixpkgs, systems, ... }:
+ let
+ eachSystem =
+ f: nixpkgs.lib.genAttrs (import systems) (system: f (import nixpkgs { inherit system; }));
+ in
+ {
+ devShells = eachSystem (pkgs: {
+ default = pkgs.mkShell {
+ buildInputs = with pkgs; [
+ zprint
+ clj-kondo
+ ];
+ };
+ });
+ };
+}